Updated System Requirements Policy - Knowledgebase / General - ASI

Updated System Requirements Policy

Authors list

To enjoy the best experience possible, as well as stay safe and secure, it is recommended that you upgrade any unsupported software to the latest version. In addition to the operating system and browser minimum requirements, it is also recommended that your PC, laptop, or tablet meet the requirements below:

  • 1 gigahertz (GHz) or faster 32-bit (x86) or 64-bit (x64) processor
  • 1 gigabyte (GB) RAM (32-bit) or 2 GB RAM (64-bit)

Your computer will still work if you continue to use unsupported software but doing so may make your computer vulnerable to security risks and viruses. Also, as ASI and other companies continue to optimize applications for only supported software, you can expect to encounter issues with devices and application incompatibility.

To ensure your internet browser is supported, it will need to be updated to the latest version. Fortunately, the default of every browser is set to update automatically so you should not have to take any action. If you are unsure if your browser is current or set to update automatically, contact your IT team.


Supported Operating Systems
  • On January 14, 2020, Microsoft ended their support of Windows 7.
  • On April 11, 2017, Microsoft ended their support of Windows Vista.

Because Microsoft has discontinued their support, ASI will no longer support Windows 7 or Windows Vista. If you are using Windows 7, Windows Vista, or other unsupported software, please consider upgrading.

To learn more about when Microsoft will end support for Windows operating systems, please review the Microsoft Windows lifecycle fact sheet. The fact sheet provides information regarding the end of support dates as well as the latest update or service pack available for each operating system.

Helpful Unhelpful